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I am experiencing request rate errors

Before you start

To complete the actions presented below, you must have:

  • A Scaleway account logged into the console
  • Owner status or IAM permissions allowing you to perform actions in the intended Organization

Problem

An error message similar to one of the following displays:

  • Error: S3 error: Too Many Requests
  • Code: Too Many Requests
  • Shared memory connection was closed.
  • Agent failed to process method {DataTransfer.SyncDisk}.

Cause

Scaleway Object Storage applies a rate limit on PUT operations for safety reasons.

Solution

Reduce the number of PUT operations sent by your deployment.

Note

You may experience reduced throughput due to the limitation.

Going further

Refer to the documentation on optimizing your Object Storage deployment.

If you did not manage to identify the error and solve it by yourself, open a support ticket, and provide as many details as possible, along with the necessary information below:

  • Object Storage Endpoint (e.g. s3.fr-par.scw.cloud)
  • Bucket name
  • Object name (if the request concerns an object)
  • Request type (PUT, GET, etc.)
  • HTTP status code
  • Date and time (timestamp)
  • User-agent (SDK, client, console, etc.)
  • Transaction ID (if possible)
  • Log / trace of the error (if possible)
Still need help?

Create a support ticket
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