Skip to navigationSkip to main contentSkip to footerScaleway DocsAsk our AI
Ask our AI

I cannot access my container

Problem

I am experiencing issues while accessing my Serverless Containers.

Possible causes

  • The container returns a DNS error or issue
  • The container response time is abnormally long
  • The container returns a HTTP 5xx error
  • The container returns a Could not resolve host error
  • The container is in an error state

Solutions

  • If you encounter a DNS issue, refer to the dedicated troubleshooting page.

  • For long response time, check:

    • if the first instance of the container is currently starting. This can entail a cold start
    • if not, check the metrics in Cockpit (especially CPU) and see if there is a high usage explaining the slow response
  • HTTP 5XX errors can come from the application itself. Check if you can reproduce locally with a dummy container, or if your application is misbehaving.

  • A Could not resolve host error can indicate that you are trying to reach the container in IPv4 with its IPv6 address, or vice versa. This can also appear if there is a DNS issue.

  • If your container is in an error state:

Still need help?

Create a support ticket
No Results