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I am experiencing DNS issues with my container

Problem

I am encountering DNS errors while using Scaleway Serverless Containers.

Possible causes

The DNS record for the default endpoint (functions.fnc.<region>.scw.cloud) is not available yet on every DNS resolver. This issue can appear even a few seconds after the container is marked as “ready”, and mostly appears when the user calls the container too early after the first deployment.

  • For custom domains, a DNS resolution failure can indicate that the custom domain is not properly configured.

Solutions

  • When the DNS answer is cached locally, you can:

    • retry later (negative DNS caching lasts around 60 seconds)
    • try from another host, where the DNS answer is not cached
    • clean the DNS cache locally
    • use another DNS resolver (common DNS resolvers should have the record in a few seconds)
  • For custom domains:

    • check the configuration on your DNS provider
    • check the TTL on the DNS record. High TTL values will cache the DNS answers for a long time, so we recommend adding a small TTL for setting up the custom domain (60s)
    • make sure you properly configured your custom domain in Serverless Containers

Going further

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