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I can't verify my identity

Problem

I can't complete the identity verification process on the Scaleway console.

Symptoms

  • You see an 'Invalid ID document' message when trying to complete the verification process
  • You receive an error message or get blocked when trying to verify your identity
  • You don't see an Upload button to send your identity for verification
  • You received the message, 'We were unable to verify your identity. Contact Support for assistance' when you tried to add your ID

Possible causes

  • The verification time has elapsed
  • The photo of your identity document is too blurred or illegible for our verification software to read
  • You are using an identification document issued by a country not yet supported by Scaleway
  • You have used an invalid document
  • You were in the process of verifying your identity and closed the window before its completion
  • Your account has raised security flags, triggering our safety system

Solution

  • If more than 15 minutes have elapsed since the start of the verification process, contact our Support team for a manual verification.
  • Take a new photo, ensuring you are in a well-lit environment, and keep the document stable, avoiding any movements.
  • Ensure you are using an accepted document. We currently accept national identity cards (including resident permits) and passports as identification documents.
  • If you abandon the verification process, you may see a status Invalid ID document. If that happens, open a support ticket, informing our agents that you left the verification process unfinished and would like to complete it.
  • If you have received a message saying that your account requires further or manual validation, contact our Trust & Safety team via a support ticket. Be prepared to provide additional documentation to complete the account verification.

Going further

If you have tried the solutions above, but they have failed, please contact our Support team, providing the following information:

  • A copy of your identity card or passport (front and back)
  • A selfie of yourself holding the same identification document provided next to your face

Our Trust & Safety team will study your request and get back to you.

Still need help?

Create a support ticket
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