I get error messages when trying to access a bucket
Before you start
To complete the actions presented below, you must have:
- Owner status or IAM permissions allowing you to perform actions in the intended Organization
Problem
One of the following messages display when trying to access your bucket using Scaleway Object Storage:
Failed to preprocess target Error: S3 error: Access Denied
Error: Shared memory connection was closed.
Failed to upload disk 'shadowSpec>'
Agent failed to process method {DataTransfer.SyncDisk}.
Cause
The application cannot access the Object Storage resource.
Solution
If you encounter one or several of the error messages above:
-
Check for issues with your API key by following this procedure.
-
Make sure that you have the
ObjectStorageFullAccess
IAM permission. -
Make sure that there is no bucket policy preventing the application to access your bucket.
Going further
- If you did not manage to identify the error and solve it by yourself, open a support ticket, and provide as many details as possible, along with the necessary information below:
- Object Storage Endpoint (e.g.
s3.fr-par.scw.cloud
) - Bucket name
- Object name (if the request concerns an object)
- Request type (PUT, GET, etc.)
- HTTP status code
- Date and time (timestamp)
- User-agent (SDK, client, console, etc.)
- Transaction ID (if possible)
- Log / trace of the error (if possible)
- Object Storage Endpoint (e.g.
Still need help?Create a support ticket