Fix Transactional Email blocked domain
Problem
My Transactional Email domain is blocked.
Cause
Domains are automatically blocked to protect the domain reputation when you have a high rate of undelivered emails.
The potential causes of undelivered emails are:
- Sending test emails to example.com or non-existing email addresses
- Importing or using a mailing list with inactive email addresses
- Sending test emails using your production environment
Solution
Identify the cause and take action to prevent blocking your domain
- Do not send emails to example.com.
- Do not send emails to non-existing or unverified email addresses.
- Use webhooks to delete emails that have soft bounced and hard bounced.
- Verify if loops or cron jobs are using wrong recipients.
- Keep a clean list of engaged users and delete email addresses of recipients that do not engage with your content.
- Separate test and production environments.
In general, follow best practices for deliverability to avoid blocking your domain.
Contact Scaleway Support
Contact Scaleway Support and specify that your domain is blocked.
- Confirm that you have identified and corrected the cause.
The support team will unblock your domain manually after verification.
Still need help?Create a support ticket