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Emails take a long time to send

Problem

My emails take a long time to send.

Cause

  • The domain or IP address is new. For new IP addresses, Transactional Email progressively grants more email volume to ensure good domain reputation. For more information, see Understanding your reputation score with TEM and Protecting domain reputation.
  • If the domain is not new, the other possible causes are:
    • Unusual email sending volume compared to your history. In this case the sending rate will be adjusted automatically.
    • The email has been greylisted by the recipient.
    • The shared IP is under pressure.

Solution

  • Send your emails progressively (100 emails/day) and slowly ramp up your volume over a period of weeks or months until you reach the desired volume.
  • Subscribe to Scale plan and use a dedicated IP if you regularly send large volumes (> 100 000 emails/month).
  • For critical needs, contact our Support team to adjust the rate limit.
  • Use webhooks to delete emails that have soft bounced and hard bounced.
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